OTC Dealer


The OTC Dealer application utilizes Java technology to provide a stable, high-performance user application experience. Dealer requires a Java Runtime Environment (JRE) version 1.6.0_14 or later.

The Dealer installer provides an up-to-date, compatible JRE; however, users can choose to use their own pre-installed JRE. OTC Dealer is only supported on Windows 2000, XP operating systems, and later. The OTC Dealer connects to OTC Markets Group's servers either through a direct connection (e.g. Radianz, Savvis) or across the public Internet. A dedicated connection is recommended when connecting over the Internet, using either a T1 (or higher), a DSL, or cable modem connection.

The following functional and technical documentation provides detailed specifications of OTC Dealer and its applicable add-on services. If you have any additional questions, please contact OTC Markets Group's Trading Services Department at tradingservices@otcmarkets.com or 1 800.547.8682

Follow Us